Artik cloud and Smartthings


#1

I had a powerbot vacuum connected with smartthings and artik. Recently my vacuum broke and had to be replaced. I am able to add the vacuum to smartthings and I am able to get the vacuum to show up in artik cloud. But I am not able to get the “artik cloud vacuum” to show up in smartthings. I have done just about everything that I can think of. removed the vacuum from all smartthings items. uninstalled artik from smartthings. Also removed all items from artik. Nothing has worked to get the artik device to show up in smartthings. The vacuum in artik also shows Unknown Availability I am stumped and out of ideas.


#2

But I am not able to get the “artik cloud vacuum” to show up in smartthings

what do you mean? show up in smartthings mobile app? If so, have you ever seen it in smartthings mobile app before your vacuum broke?
Per my understanding, only limited ARTIK cloud device types can be shown in SmartThings mobile app.

The vacuum in artik also shows Unknown Availability

The device shown unknown if this device never connected to ARTIK Cloud per “persistent connection” which is defined at https://developer.artik.cloud/documentation/glossary.html

Can you see any data or Actions in data logs from this device?


#3

yes in the smartthings app. It has shown up as “artik samsung vacuum” in smartthings and I actually had this one added back in and showing up and controllable through the “artik switch” created in smartthings today. But my webcore piston would not fire off so I removed everything and since then I have not had any luck getting it to show back up.

for example if I go back into my smartthings Hub logs. This is from earlier today…
2018-03-23 5:38:15.242 PM EDT
4 hours ago DEVICE switch on ARTIK Robot vacuum switch is on

ARTIK Robot vacuum switch is on
Name Value
archivable true
data
{
“microDeviceTile”: {
“type”: “standard”,
“icon”: “st.Appliances.appliances17”,
“backgroundColor”: “#00a0dc
}
}
date 2018-03-23 5:38:15.242 PM EDT (2018-03-23T21:38:15.242Z)
description ARTIK Robot vacuum switch is on
deviceId 03ae4cc0-be1f-4e4b-b40f-19d9d3e490b4
deviceTypeId b7f867ac-0cf0-4fa8-8799-480469a62f41
displayed true
eventSource DEVICE
hubId
id 7e5eaaa0-2ee2-11e8-b792-026e3a64e7fe
isStateChange true
isVirtualHub false
linkText ARTIK Robot vacuum
locationId 6e9aa2d6-35bb-4b98-870a-f14f909a4ed8
name switch
rawDescription
translatable false
unixTime 1521841095242
value on
viewed false


#4

and here are some logs from artik from yesterday when i had it working.

Deleted Device Mar 22 2018 19:00:53.889 Mar 22 2018 19:00:54.010
{“name”:“Robot vacuum”,“deviceSubType”:"",“id”:“9836647F-DFCF-DD4D-09C1-E7C448346F45”,“Mode”:{“modes”:[“Cleaning_Stop”,“Control_Charging”,“Access_UnLock”,“Turbo_Silence”,“RepeatedCleaning_On”]},“resources”:[“Mode”],“connected”:true,“type”:“Robot_Cleaner”}
Deleted Device Mar 22 2018 18:59:38.359 Mar 22 2018 18:59:38.495
{“name”:"",“deviceSubType”:"",“id”:“9836647F-DFCF-DD4D-09C1-E7C448346F45”,“Mode”:{“modes”:[“Cleaning_Stop”,“Control_Charging”,“Access_UnLock”,“Turbo_Silence”,“RepeatedCleaning_On”]},“resources”:[“Mode”],“connected”:true,“type”:“Robot_Cleaner”}
Deleted Device Mar 22 2018 18:59:28.082 Mar 22 2018 18:59:28.102
{“name”:"",“deviceSubType”:"",“id”:“9836647F-DFCF-DD4D-09C1-E7C448346F45”,“Mode”:{“modes”:[“Cleaning_Stop”,“Control_Charging”,“Access_UnLock”,“Turbo_Silence”,“RepeatedCleaning_On”]},“resources”:[“Mode”],“connected”:true,“type”:“Robot_Cleaner”}
Deleted Device Mar 22 2018 18:58:40.787 Mar 22 2018 18:58:40.806
{“name”:"",“deviceSubType”:"",“id”:“9836647F-DFCF-DD4D-09C1-E7C448346F45”,“Mode”:{“modes”:[“Cleaning_Stop”,“Control_Charging”,“Access_UnLock”,“Turbo_Silence”,“RepeatedCleaning_On”]},“resources”:[“Mode”],“connected”:false,“type”:“Robot_Cleaner”}


#5

Hi @DAVID_WOOLFORD, thank you for sharing the above information. It has been shared with our development team and apologize for delay in response.

Could you also let us know if the following steps help resolve via SmartThings app?

SmartThings Mobile Applications > Automation > SmartApps > ARTIK Cloud SmartApp > “2. Synchronize ARTIK Cloud and SmartThings devices”


#6

thank you for responding. I tried that and that did not work. The vacuum still shows up in artik but there is no “artik” device in the smartthings app.


#7

What I am reading above is you have replaced your existing vacuum device to a new one.

Hi @DAVID_WOOLFORD, our development team has provided the following to begin debugging the issue:

  1. Can you help confirm using the latest version of this app? “https://play.google.com/store/apps/details?id=com.samsung.smarthome

  2. Login into my.artik.cloud -> ARTIK Cloud account > Devices
    Click on the “Robot vacuum” device currently in your account
    Check and send us the Device Type ID (DTID) which should be dtce6ab67e9251488ea7652ece3110557a


#8

that is correct my vacuum of the same exact model quit working and was replaced. I was able to add the new vacuum into smart things originally but could not get it to respond. So then removed it and since then i have not been able to re-add it back into smart things as far as the “artik device” which was in it prior to all this.

My device is IOS

DEVICE TYPE ID
dt57f10e27199f44e88f9bf1845d67893f

I did notice today that suddenly the vacuum shows that it was added on artik yesterday and now instead of unknown status it shows online. But i am still unable to find it or get it to show up in smartthings. I have verified that it is all set up like it was prior to all this.


#9

Thanks for info. Let me check with the developers here regarding this.

From what I understand, do you have the Vaccuum working at all without involving ARTIK Cloud? For example, just using SmartThings app?


#10

yes, it does work in smart things. Now that i have figured out the exact wording for the commands i have been able to get my webcore piston to work with just smartthings. Artik made the integration easy and without the Artik logs I had I would have never been able to figure out the correct wording for the commands to get it to run. As in my set up I only want the vacuum to run when our presence sensors are not present. So while my true problem still exists i have found a workaround or more direct way to accomplish what I wanted to accomplish.


#11

@DAVID_WOOLFORD, thanks for the update. Are you okay with me resolving this ticket?

For questions relating to webcore piston you might like to reach directly out to smartthings community at:
https://community.smartthings.com

If you are still trying to link this device to ARTIK Cloud, you can use the SmartThings mobile app and follow these steps:

On SmartThings Mobile Application :
Go to Automation > SmartApps
Click on “ARTIK Cloud”
Synchronize the devices
Wait few minutes and verify device available in your my.artik.cloud account.


OM-5753


#12

EDIT to above:

Developers have provided me the following info: If you are trying to link this device to ARTIK Cloud, here is 1st way as mentioned in previous post:

On SmartThings Mobile Application :
Go to Automation > SmartApps
Click on "ARTIK Cloud"
Synchronize the devices

or, alternatively directly from AKC (ARTIK Cloud) user portal:

1. Login to AKC user portal (my.artik.cloud) > devices
2. Add the "Samsung SmartHome Devices" to ARTIK Cloud account (or simply follow this link) https://my.artik.cloud/devices/new/io.samsungsami.samsungsmarthome.devices?device_name=My+Samsung+Smart+Home&authorize=true
3. Link your account with SmartThings by logging in and granting permissions.

OM-5753


#13

will give it a shot and i appreciate all the help and you can close this if you like. Also just to make things even more weird… Is after i went to the second link the vacuum name changed and is actually able to be controlled from the artik dashboard which did not work prior. BUT still not visible in the smartthings app at all.


#14

Hi @DAVID_WOOLFORD, thank you for advising initial problem and indicating okay for closing issue.

For subsequent issue you mention, if still problematic, can you file a separate issue in the forum? In this case, you are reporting you are able to control robot vacuum via ARTIK cloud, however, this device is not visible in app. This will allow development team to take further look into this.


#15

At this point I am not sure it is a ARTIK issue. As it is not showing up in the SmartThings app. But thanks for all your help.


#17

where is vacuum link ?


#18

Hi Charles, you can check the SmartThings app to connect one of the compatible robot vacuums using the SmartThings app:

However, I’m unsure at this very time if this device is compatible to synchronize your device to ARTIK cloud using this app. You may want to check back later.